Componette

Componette

contributte

contributte / api-router v2.1.1

RESTful router for your API in Nette Framework (@nette). Created either directly or via annotation.

download-cloud-line composer require ublaboo/api-router

Website 🚀 contributte.org | Contact 👨🏻‍💻 f3l1x.io | Twitter 🐦 @contributte

Usage

To install the latest version of contributte/api-router use Composer.

composer require contributte/api-router

Documentation

For details on how to use this package, check out our documentation.

Versions

State Version Branch Nette PHP
stable ^4.0.0 master 3.0+ ^7.1

Development

See how to contribute to this package.

This package is currently maintaining by these authors.


Consider to support contributte development team. Also thank you for using this package.

  • v2.1.1 v2.1.1

    Bump!

    • less strict requirements for doctrine/cache

    Diff: v2.0.3...v2.1.1

  • v4.0.0 v4.0.0

    Bump!

    • ublaboo/api-router -> contributte/api-router

    Diff: v3.0.0...v4.0.0

  • v3.0.0

    BC Breaks:

    • nette 3
  • v2.0.3 v2.0.3

    • Allow ApiRouteSpec::$description to be null
  • v2.0.0 v2.0.0

    Added

    • Composer requires php 7.1
    • Travis requires php 7.1
    • Using php 7.1 return types + method argument types declarations

    Fixed

    • ApiRouterExtension: add ApiRouter annotated presenter route only if there are some remaining methods without ApiRouter annotated presenter method
Componette Componette felix@nette.org