Componette

Componette

nettrine

nettrine / annotations v0.7.0

Standalone Doctrine Annotations for Nette Framework

download-cloud-line composer require nettrine/annotations

Website ๐Ÿš€ contributte.org | Contact ๐Ÿ‘จ๐Ÿปโ€๐Ÿ’ป f3l1x.io | Twitter ๐Ÿฆ @contributte

Usage

To install the latest version of nettrine/annotations use Composer.

$ composer require nettrine/annotations

Documentation

For details on how to use this package, check out our documentation.

Versions

State Version Branch Nette PHP
dev ^0.8 master 3.0+ >=7.2
stable ^0.7 master 3.0+ >=7.2
stable ^0.4 master 2.4 ^7.1

Development

See how to contribute to this package.

This package is currently maintaining by these authors.

Sponsoring


Consider to support contributte development team. Also thank you for using this package.

  • v0.7.0 v0.7.0

    Bumped! โ„น๏ธ

    Diff: v0.6.2...v0.7.0

    Changes

    • PHP 8
    • Travis -> Github Actions
    • Use nettrine/cache v0.3
    • Use contributte/di v0.5
  • v0.6.2 v0.6.2

    Bumped! ๐Ÿ“„

    Diff: v0.6.1...v0.6.2

    Changes

    • Use nettrine/cache v0.2
  • v0.6.1 v0.6.1

    Bumped! ๐Ÿ“ฆ

    Diff: v0.6.0...v0.6.1

    Changes

    • Rely on nettrine/cache directly 9b3cf66
    • Polish readme + doc
  • v0.6.0 v0.6.0

    Bumped! ๐Ÿจ

    Diff: v0.5.0...v0.6.0

    Changes: 7a3010f

    • annotations persistent and serializationVersion are ignored by default
    • cache config accepts only services, referencing cache by name filesystem, apcu etc. is not possible
    • an autowired cache is used by default (nettrine/cache is recommended)
  • v0.5.0 v0.5.0

    Bumped! ๐Ÿ“Ÿ

    Diff: v0.4...v0.5.0

    Changes:

  • v0.4 v0.4

    Bump! ๐Ÿ•น
    Diff: v0.3...v0.4

    Changes:

    • Upgrade composer dependencies
    • Require doctrine/cache >=1.7.1
    • More tests
  • v0.3 v0.3

    Bump! ๐Ÿ‡ซ๐Ÿ‡ฐ

    Diff: v0.2...v0.3

    Changes:

    • Turn off autowiring for cache drivers (thanks @jiripudil) [#6]
  • v0.2 v0.2

    Bump! ๐Ÿญ

    Diff: v0.1...v0.2

    Changes:

    • require PHP 7.1 [#4]
    • unlock dependencies [#5][#3]
    • use registerUniqueLoader [#2]
  • v0.1 v0.1

    First bump! ๐Ÿ‘Š

bar-chart-fill

Statistics

download-cloud-fill
227579
star-fill
14
bug-fill
1
flashlight-fill
8d
price-tag-2-line

Badges

guide-fill

Dependencies

php (^7.2)
nette/di (~3.0.0)
Componette Componette felix@nette.org