Statistics
221585
27
3
27d
Badges
Dependencies

Nettrine Migrations

Doctrine/Migrations for Nette Framework.

Website 🚀 contributte.org | Contact 👨🏻‍💻 f3l1x.io | Twitter 🐦 @contributte

Usage

To install the latest version of nettrine/migrations use Composer.

composer require nettrine/migrations

Documentation

For details on how to use this package, check out our documentation.

Versions

State Version Branch Nette PHP
dev ^0.7 master 3.0+ ^7.2
stable ^0.6 master 3.0+ ^7.2
stable ^0.5 master 2.4 ^7.1

Development

See how to contribute to this package.

This package is currently maintaining by these authors.


Consider to support contributte development team. Also thank you for using this package.

  • v0.6.2 v0.6.2

    Diff: v0.6.1...v0.6.2

    Changes:

    • Polish doc & readme
  • v0.6.1 v0.6.1

    Diff: v0.6.0...v0.6.1

    Changes:

    • Allows symfony/console ^5.0.0 bc7a2cb
  • v0.6.0 v0.6.0

    Diff: v0.5...v0.6.0

    Changed:

  • v0.5 v0.5

    Bump! 🏷

    Diff: v0.4...v0.5

    Changes:

    • use doctrine/migrations 2.0
    • added customTemplate (thanks @RiKap)
  • v0.4 v0.4

    Bump! 🔒

    Diff: v0.3...v0.4

    Changes:

    • upgrade deps
    • added console.command for DIC services (@mabar)
    • improve docs (@JanMikes)
  • v0.3 v0.3

    Bump! *️⃣

    Diff: v0.2...v0.3

    Changes:

    • minimal PHP >= 7.1 [#5]
    • allow Symfony Console 4.x
  • v0.2 v0.2

    Bump! 💃

    Diff: v0.1...v0.2

    Changes:

    • update CI process
    • added phpstan
    • update quality assurance
    • register helper at compile time (e457045)
    • readme for kdyby integration (8410bb0)

    Integration with Kdyby\Console.

    decorator:
        Symfony\Component\Console\Command\Command:
            tags: [kdyby.console.command]
        Symfony\Component\Console\Helper\Helper:
            tags: [kdyby.console.helper]
  • v0.1 v0.1

    Bump! 👊

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com